New SDK, New IDE

Upgraded my iPad2 to be using iOS5 and realised I needed the new SDK in order to build to a iOS5 device. After a 1.6gb download and install, I was faced with a shiny new XCode IDE. Fiddled around a little around to oriented myself with the new IDE. Cleaned the build and built to device, yep, no issues. Problem came when I tried to build to a iOS4.0 Simulator, fatal error.

dyld: Library not loaded: /usr/lib/libc++abi.dylib

Issue and solution highlighted in the following forum thread : http://www.cocos2d-iphone.org/forum/topic/19384